Users login

Create an account »

JOIN XATRIX

Users login

Home » Hacking News » Web-erp 0.1.4 database access vulnerability

Web-erp 0.1.4 database access vulnerability

by Nikola Strahija on March 2nd, 2003 Product web-erp have database access vulnerability.


Introduction
============
>From web site:
"WEB-ERP aims to provide a company with all the tools it needs to manage
multi-currency debtors, multi-location stocks, multi-currency creditors as
well as it's general accounting needs."

=====================
Vulnerability Details
=====================
1) FULL DATABASE ACCESS

http-requests to:

---*---
http://server/logicworks.ini
---*---

display the contents of this configuration file, unless the web server is
specifically configured to handle .ini files differently. The contents
include the MySQL username and password used by the application. With this
username/password, a malicious person could connect to MySQL direct and add,
modify, and delete data.

severity: HIGH



=======
Remarks
=======
The author was very responsive and released a new, corrected version the
same day.

This vulnerability report was made using a recent post by Martin Eiszner as
a template. Any similarity is no coincidence.


====================
Recommended Hotfixes
====================
Upgrade to 0.1.5, which the author reports fixes this problem.

Product: web-erp 0.1.4 and earlier
Vulnerabilities: full database access
Vendor: Phil Daintree (http://web-erp.sourceforge.net/)
Vendor-Status: E-Mail to "[email protected]" date: 27.02.2003
Vendor-Patch: Vendor reports problem fixed in new version 0.1.5 (27.02.2003)

Local: YES
Remote: YES

=======
Contact
=======

Ryan Fox
[email protected]


Newsletter signup

Signup to our monthly newsletter and stay in touch with IT news!

Free E-books

We've got ebooks! But they're not online. :( Please give us a few days to bring downloads back.

Contact

Have something to say or just wanna drop us a line? Please keep this in mind: to spam, we reply with spam.

Contact us »