Users login

Create an account »


Users login

Home » Security Advisories» Ubuntu » libnl vulnerability

libnl vulnerability

  • Vendor: Ubuntu
  • Vendor ID: USN-3311-1
  • Date: June 06, 2017

Ubuntu Security Notice USN-3311-1
June 06, 2017

libnl3 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.04
- Ubuntu 16.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS


libnl could be made to crash or run programs.

Software Description:
- libnl3: library for dealing with netlink sockets


It was discovered that libnl incorrectly handled memory when performing
certain operations. A local attacker could possibly use this issue to cause
libnl to crash, resulting in a denial of service, or execute arbitrary

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.04:
libnl-3-200 3.2.29-0ubuntu2.1

Ubuntu 16.10:
libnl-3-200 3.2.27-1ubuntu0.16.10.1

Ubuntu 16.04 LTS:
libnl-3-200 3.2.27-1ubuntu0.16.04.1

Ubuntu 14.04 LTS:
libnl-3-200 3.2.21-1ubuntu4.1

After a standard system update you need to reboot your computer to make
all the necessary changes.


Package Information:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <>

Newsletter signup

Signup to our monthly newsletter and stay in touch with IT news!

Free E-books

We've got ebooks! But they're not online. :( Please give us a few days to bring downloads back.


Have something to say or just wanna drop us a line? Please keep this in mind: to spam, we reply with spam.

Contact us »