Users login

Create an account »


Users login

Home » Security Advisories» Ubuntu » KDE-Libs vulnerability

KDE-Libs vulnerability

  • Vendor: Ubuntu
  • Vendor ID: USN-3286-1
  • Date: May 15, 2017

Ubuntu Security Notice USN-3286-1
May 15, 2017

kde4libs vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.04 LTS


KDE-Libs could be made to run programs as an administrator if it received
specially crafted input.

Software Description:
- kde4libs: KDE 4 core applications and libraries


Sebastian Krahmer discovered that the KDE-Libs Kauth component incorrectly
checked services invoking D-Bus. A local attacker could use this issue to
gain root privileges.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.04 LTS:
kdelibs5-plugins 4:4.13.3-0ubuntu0.5

After a standard system update you need to reboot your computer to make
all the necessary changes.


Package Information:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <>

Newsletter signup

Signup to our monthly newsletter and stay in touch with IT news!

Free E-books

We've got ebooks! But they're not online. :( Please give us a few days to bring downloads back.


Have something to say or just wanna drop us a line? Please keep this in mind: to spam, we reply with spam.

Contact us »