Users login

Create an account »

JOIN XATRIX

Users login

Home » Security Advisories» OpenPKG » Curl denial of service

Curl denial of service

Two off-by-one errors in libcurl's URL parser allow a buffer overflow and cause a DoS via certain URLs that are malformed in a way that prevents a terminating NUL byte from being added to either a hostname or path buffer, or contain a "?" separator in the hostname portion, which causes a "/" to be prepended to the resulting string.

  • Vendor: OpenPKG
  • Vendor ID: SA-2005.028
  • Date: December 10, 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

________________________________________________________________________

OpenPKG Security Advisory The OpenPKG Project
http://www.openpkg.org/security.html http://www.openpkg.org
[email protected] [email protected]
OpenPKG-SA-2005.028 10-Dec-2005
________________________________________________________________________

Package: curl
Vulnerability: denial of service
OpenPKG Specific: no

Affected Releases: Affected Packages: Corrected Packages:
OpenPKG CURRENT <= curl-7.15.0-20051206 >= curl-7.15.1-20051207
<= openpkg-20051206-20051206 >= openpkg-20051207-20051207
OpenPKG 2.5 <= curl-7.15.0-2.5.0 >= curl-7.15.0-2.5.1
<= openpkg-2.5.0-2.5.0 >= openpkg-2.5.1-2.5.1
OpenPKG 2.4 <= curl-7.14.0-2.4.1 >= curl-7.14.0-2.4.2
<= openpkg-2.4.2-2.4.2 >= openpkg-2.4.3-2.4.3
OpenPKG 2.3 <= curl-7.13.0-2.3.1 >= curl-7.13.0-2.3.2
<= openpkg-2.3.5-2.3.5 >= openpkg-2.3.6-2.3.6

Dependent Packages: aegis, apache [with_mod_php_curl=yes],
clamav, heartbeat, perl-net [with_curl=yes],
php [with_curl=yes], php5 [with_curl=yes],
vorbis-tools, xine-ui

Description:
According to a vendor security advisory [0], a Denial of Service (DoS)
vulnerability exist in "libcurl", the underlying library of the cURL
[1] networking tool.

Two off-by-one errors in libcurl's URL parser allow a buffer overflow
and cause a DoS via certain URLs that (1) are malformed in a way
that prevents a terminating NUL byte from being added to either
a hostname or path buffer, or (2) contain a "?" separator in the
hostname portion, which causes a "/" to be prepended to the resulting
string.

The Common Vulnerabilities and Exposures (CVE) project assigned the id
CVE-2005-4077 [2] to the problem.
________________________________________________________________________

References:
[0] http://curl.haxx.se/docs/adv_20051207.html
[1] http://curl.haxx.se/
[2] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4077
________________________________________________________________________

For security reasons, this advisory was digitally signed with the
OpenPGP public key "OpenPKG " (ID 63C4CB9F) of the
OpenPKG project which you can retrieve from http://pgp.openpkg.org and
hkp://pgp.openpkg.org. Follow the instructions on http://pgp.openpkg.org/
for details on how to verify the integrity of this advisory.
________________________________________________________________________

-----BEGIN PGP SIGNATURE-----
Comment: OpenPKG

iD8DBQFDm0N3gHWT4GPEy58RAnPTAJ97DU/DXsm1lFjasyWt1/WEOtQoDgCgiCIX
P2G7Ly7rjQvpV4/m8f3mhjo=
=BnuL
-----END PGP SIGNATURE-----

Newsletter signup

Signup to our monthly newsletter and stay in touch with IT news!

Free E-books

We've got ebooks! But they're not online. :( Please give us a few days to bring downloads back.

Contact

Have something to say or just wanna drop us a line? Please keep this in mind: to spam, we reply with spam.

Contact us »